Kako se pripraviti na jQuery posodobitev v WordPress različici 5.7?


Številna spletna mesta, teme in vtičniki se še vedno zanašajo na starejše jQuery različice in jih bo treba posodobiti skupaj s posodobitvijo WordPress-a na različico 5.7. V kolikor omenjenega ne boste storili, lahko na vaši spletni strani pride do težav
.

Kaj je jQuery?

jQuery je JavaScript knjižnica. Velik del funkcionalnosti urejevalnika WordPress se opira na jQuery.

Zakaj posodobitev?

WordPress že vrsto let uporablja starejšo jQuery različico. Posodobitev prinaša večjo stopnjo varnosti ter učinkovitosti za vašo WordPress stran. Pomeni pa tudi, da nekatere funkcije na vašem spletnem mestu morda ne bodo delovale tako, kot pričakujete.

Kako lahko pripravim svojo spletno stran?

Seznanite se s spremembami

jQuery je objavil izčrpen priročnik za pomoč pri posodobitvi. Vključuje poglavje, ki se osredotoča na uporabo jQuery Migrate vtičnika za potrebe testiranja.

Postavite mesto za testiranje

Preden namestite WordPress 5.7, preizkusite delovanje spletnega mesta v varnem razvojnem okolju.

To lahko storite na nekaj načinov:

  • Ustvarite poddomeno, kot je test.vasadomena.si, in na njej ustvarite kopijo svojega spletnega mesta.
  • Ustvarite lokalno različico svojega spletnega mesta za testiranje. »Lokalno« je le izraz za zagon vašega spletnega mesta naračunalniku. Local by Flywheel in MAMP sta dve odlični možnosti.
  • Testiranje posodobitve, preden jo namestite na svoje spletno mesto, je ključno za preprečevanje težav.

Uporabite Pomočnika za jQuery selitev

Skupina WordPress je pripravila ta vtičnik, da bi vnaprej prepoznal morebitne težave, do katerih na vaši spletni strani ob posodobitvi lahko pride. Prav tako lahko vaše spletno mesto povrne na starejšo jQuery različico, če posodobljena različica povzroči težave. Več o jQuery pomočniku za selitev je možno najti tukaj.

Pomoč! Posodobil sem WordPress 5.7 in sedaj imam težave s Koledarjem. Kaj storiti?

  • Prepričajte se, da sta različici WordPress in Koledar dogodkov sinhronizirani
  • Preverite različico vsakega od naših vtičnikov, ki jih uporabljate. Poskrbite, da imate najnovejše različice vseh naših vtičnikov, če uporabljate WordPress 5.7 in novejše.
  • Znova namestite staro različico WordPressa
  • Uporabite Pomočnika za jQuery selitev
Vam je članek pomagal?
Dislike 0
Ogledov: 11
Niste našli, kar ste iskali? Preiščite bazo znanja